Alias E-Mail as primary Address?

I use Germany’s “” service (DE=Germany), and thus have to log in with the “.DE” domain. Yet, I use my alias E-Mail as my standard that comes with an “posteo.AT” domain. I want that messages sent from Delta show my address with the AT domain and not with DE. Is there any work around?
Cheers from Vienna

You can try to set .de email server manually in the advanced settings and set your From address to .at. I don’t know if Posteo accepts it this way.