Backing up takes forever (android, apk)

Delta Chat version

1.1.2 (installed from apk on android)

Expected behavior

A backup is created.

Actual behavior

A dialog with “One moment” and a cancel button stays there.

Steps to reproduce the problem

  1. Start a backup

Debug logs
I’m not seeing anything in the logs…

I installed the fdroid version (this was the motivation to do the backup) and I tried doing a backup from it. It works. So it must be something with the apk version.

Hi :slight_smile: I just tried to reproduce it.

for me it works, with apk 1.1.2 on LineageOS 16.0. It shows the “One Moment… xx%”, and completes at 100%.

Which Android version are you using? How many free space do you have on your device?

Thank you for testing. I’m on LineageOS 16.0 (January 14), and I have 18 GB free. The “…%” part never shows, so I get it’s stuck before even starting to backup.

I guess you could try downgrading by re-installing an earlier apk, and then exporting a backup from the earlier version. But I’m not entirely sure that’s safe, and if it’s not really urgent, maybe better don’t^^

As far as I know downgrading android apps is not possible.

fdroid has an option to downgrade… but I don’t know if that just deletes the apk and install the old version

This happens to me frequently when I have the device connected to a WiFi network without Internet, maybe the problem, Delta tries to connect to the server before doing the backup,

Interesting. Which server? The email server?


Close the connection completely (data or WiFi) and try again.

I’ve put my phone in airplane mode and I see the same thing. I’m not sure this is the problem as the other instance of Delta Chat (installed using fdroid) was able to backup.

This happened to me when IMAP thread died because of a bug that is already fixed. Try putting the phone in airplane mode (as suggested above), reboot it and then initiate a backup

1 Like

Thank you. I just tried this and it still does not work. I think I’ll wait until the next version to see if it is fixed.

So I tried to create a backup for the desktop app (it fails: I am asked a location to save the backup, and nothing happens), but as I did it I saw that the Android Delta Chat had actually created some backups in my Downloads folder. I imported the last one and it worked (with one exception: the profile picture is not shown in the imported chat).

So I guess the issue is not that the backup is failing, but that the dialog to create it does not go away when it’s done.