Can't login into my office 365 work account

Hi everyone. I hope I can get some help with the following issue.

Delta Chat version

Expected behavior
Login into my office 365 work account

Actual behavior
The following error
Trying imap: k******* security=Ssl certificate_checks=strict oauth2=false socks5_config=None… Error: Cannot login as "k@m***********p". Please check if the e-mail address and the password are correct. no response: code: None, info: Some(“LOGIN failed.”)

This is a snippet of the actual error message. The actual message continues by repeating the same message above but changing a few parameters: ports and login username.
Steps to reproduce the problem
Not sure if others can reproduce it since it is a work account. I login normally. My employer is using a login verification system where they send us a one-time code to our other email. I thought it might have been the issue, but then I tried logining in at work using the local network that doesn’t require verification on login, but I still got the same error. Any ideas what could be causing it?



Sounds like you’ll need an App Password because of the two factor authentication set by your employer.

That should work, if not there might also be other restrictions in place on the account by the organisation (some may restrict SMTP / IMAP access).


Thanks for the reply. I am not entirely sure it is what I need. My organization doesn’t allow app passwords, unfortunately, but I smtp/imap access should be working fine. I have tried many mail apps, and it works. Spike, for example, a paid alternative to Delta, works fine. It picks up the server automatically and then opens a popup with my organization login page where I can login normally and also input the one-time password emailed to me after that. I was hoping DeltaChat would be able to do something similar somehow?

This sounds like they support OAuth2 for this server, and Delta Chat doesn’t.

1 Like

I see. Thanks. I figured it was something of this sort. Too bad. :disappointed_relieved: