DC on older devices

Good DC-team, developer, user,

my person thought good to give feed-foward/back in tellling that DC might not ork on older devices (like huawei media pad t17.0 andoid 4.4.2). It crashes when open. (generously given old repaired, and just tried)

Version 1.26.6 run earlier on the old device.

can you get some log of the crash? maybe this app works if not you’ll need a computer: Logcat Reader | F-Droid - Free and Open Source Android App Repository

Appreciation for effort, yet not proper to make use (not knowing the owner), good Simon.

According to Huawei MediaPad T1 7.0 - Full tablet specifications it uses Spreadtrum SC7731G SOC.
It has a 32-bit ARM CPU (armeabi-v7a arch instead of common arm64-v8a) that we support but don’t test frequently.

Appreciation for efforts. My person could find older version, 1.42.6 and installing, opening worked and all seems fine.

(like always my person suggest that issues are related to efforts aside the main purposes, original purpose)

So https://download.delta.chat/android/deltachat-gplay-release-1.44.0.apk does not work, but https://download.delta.chat/android/deltachat-gplay-release-1.42.6.apk works?

1.42.6 used core 1.131.9 and 1.44.0 used core 1.136.2 according to the Android changelog: deltachat-android/CHANGELOG.md at 9c869a9f7622e846aa82a8c0599e2c4030158d37 · deltachat/deltachat-android · GitHub

I am going to try debugging it by installing emulator and system-images-android-19-default-armeabi-v7a (19 corresponds to Android 4.4).

EDIT: current Android emulator refuses to run android-19. The oldest one I managed to run is android-23, but emulation is too slow to be usable.


i created an issue at trying to on android4 crashes immediately · Issue #3027 · deltachat/deltachat-android · GitHub

1 Like

good news: on the upcoming delta chat 1.46, android4 runs again, at least in our tests, see trying to start on android4 crashes immediately · Issue #3027 · deltachat/deltachat-android · GitHub