Delta.Chat Desktop does not start on Debian 10 (buster)

Delta.Chat 0.104 package for Ubuntu 19.10 installs fine on Debian 10, but when it is launched it shows this dependency error.

$ deltachat-desktop 
/opt/DeltaChat/deltachat-desktop-electron: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/DeltaChat/libdeltachat/lib/x86_64-linux-gnu/libdeltachat.so)
/opt/DeltaChat/deltachat-desktop-electron: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/DeltaChat/rpgp/lib/librpgp.so)

Can this be fixed by the dev team? Should I create an issue over on github?

Should Debian users install from flathub?
It is currently two minor versions behind, but a pull request is already made to version 1.4., but it has issues.

Tested flathub: Installing and running Version 1.2 works.

I would use the flathub version or install the libC library in the required version manualy and use the deb.
Alternativly you could run it from master (the absolute newest version that isn’t released yet):

  1. install rustup and nodejs
  2. clone dc-desktop with git clone https://github.com/deltachat/deltachat-desktop.git
  3. cd into deltachat-desktop
  4. run npm i to install dependencies (compile core + get js packets that are needed)
  5. run npm build

Then to start run npx electron .

After doing git pull in the future repeat steps 4 and 5.

1 Like

For convenience I would use either flathub or the deb file.
I think I’ll stick with flathub to get updates automatically. I hope the flathub version will be updated regularly in the future. We’ll see.

1 Like

Ubuntu 18.04 LTS ~ Debian 10 in packages versions. Install and try again because it could be a problem with that first.

I tried to install the 18.04 package through apt. Apt says:

 deltachat-desktop : Depends: libssl1.0.0 but it is not installable

I am interested in this method to test the latest core/features etc, is this command (npx electron .) the same as the “npm start” that is mentioned in the deltachat-desktop readme?? also the readme says npm run build instead of npm build I don’t know anything about nodejs, are that commands equivalent??

Did you used apt or dpkg? could you try installing libssl1.0.2 first? I didn’t check if the package request =1.0.0 or >= 1.0.0

no, npm start does set some development flags, see https://github.com/deltachat/deltachat-desktop/blob/master/package.json#L17

npm run build is technically more correct. Though some commands such as start and test work also without it.

1 Like

@EchedeyLR:

Did you used apt or dpkg? could you try installing libssl1.0.2 first? I didn’t check if the package request =1.0.0 or >= 1.0.0

I installed through apt.
I tried to install libssl:

sudo apt install libssl1.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libssl1.1 is already the newest version (1.1.1c-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Then I installed DeltaChat 18.04 deb file again:

sudo apt install ./DeltaChat-ubuntu-18_04-0.104.0.deb 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'deltachat-desktop' instead of './DeltaChat-ubuntu-18_04-0.104.0.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 deltachat-desktop : Depends: libssl1.0.0 but it is not installable
E: Unable to correct problems, you have held broken packages.

libssl1.1 no

2019-09-05_18-26

Edited: I tested it, dependencies are not configured in the good way.

Mmm Same version, different name. It seems a specific problem but in general every stable version of Debian is equivalent to every LTS version of Ubuntu.