Delta.Chat desktop installation on debian


#1

I tried to install the deb package under debian 9.5 64bit, installation with gdebi finished successfully, but when I start the application Delta.Chat, nothing happens. Tried to install as root and user but no difference.
Any ideas what I make wrong?


#2

Can you try starting the application from command line? E.g.

$ /opt/Delta.Chat/deltachat-desktop

Might be some libs missing, e.g. libssl or something.

For the record, I installed it myself with sudo dpkg -i deltachat-desktop_1.4.0_amd64.deb


#3

If I started Deltachat-desktop only an empty white window is given.
I get following error in terminal

(node:4509) Warning: N-API is an experimental feature and could change at any time.
A JavaScript error occurred in the main process
Uncaught Exception:
Error: ENOENT: no such file or directory, scandir ‘/home/xxxxx/.config/DeltaChat’
Missing config file: Creating new one<


#4

Hello all.

I experience similar under Linux Mint 18.3. For both the *.Appimage and *.deb on both versions 1.4.0 and 1.3.0 I see after program start only a white window under the grey menue. Is there any additional (manual) step required as part of the installation process? For the *.deb the check on dependencies does not complain about anything missing.

regards,
Sven


#5

Aha, in fact now I see more information:

/opt/Delta.Chat$ deltachat-desktop
A JavaScript error occurred in the main process
Uncaught Exception:
Error: libssl.so.1.0.0: Kann die Shared-Object-Datei nicht oeffnen: Datei oder Verzeichnis nicht gefunden
at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:166:20)
at Object.Module._extensions…node (module.js:671:18)
at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:180:18)
at Module.load (module.js:561:32)
at tryModuleLoad (module.js:504:12)
at Function.Module._load (module.js:496:3)
at Module.require (module.js:586:17)
at require (internal/module.js:11:18)
at load (/opt/Delta.Chat/resources/app.asar/node_modules/node-gyp-build/index.js:13:10)
at Object. (/opt/Delta.Chat/resources/app.asar/node_modules/deltachat-node/binding.js:1:198)


#6

I installed “deltachat-desktop_1.7.0_amd64.deb” on ubuntu 18.04.
First time, after installation, i had only a white window under the grey menue too (as already mentioned).
After a reboot of the system and starting Delta.Chat it starts with an window i have to enter my E-Mail-adress and my password.
After quitting Delta.Chat and starting once again Delta.Chat starts always with the window where i have to enter my E-Mail-adress and my password.
Seams that E-Mail-adress and password is not saved.


#7

Hey all, thanks for reporting and sorry that someone haven’t replied to any of your problems until now.

The problem with scandir '/home/whatever/.config/DeltaChat' is known and fixed.
Also, the problem with libssl.so.1.0.0 should also be fixed, starting from version v2.0.0 (we built the app on an older version of ubuntu, which caused problems for debian users).

In the future, if you find more bugs, please report them directly on https://github.com/deltachat/deltachat-desktop/issues

Cheers
/rtn


#8

We now save successfully configured logins, so once you have logged in, there should be a button on the login page for that account. Next time you start the application, just click on that button. So no need to fill in username and password again.

Cheers
/rtn


#9

I found the button.
It’s at the login-screen above the 'E-Mail Address" and it works easily.
Thanks for that information.


#10

Now it works also on debian with the 2.0.0 deb package, thanks!