Deltachat Desktop latest git still opens to white screen on wayland Manjaro

Delta Chat version Version 1.22.2 (git: v1.20.3-201-gcfa48d47)
Manjaro unstable, up to date
electron v15.1.1

Hello, just wanted to let you know

For some reason deltachat desktop is opening to a white screen with the Wayland flags ie. --enable-features=UseOzonePlatform --ozone-platform=wayland
working ok on window
other electron apps working ok on wayland only seems to be deltachat
Have tried a reinstall with a brand new profile but still the same.
Wondered if it was related to this but not sure to be honest fix whitescreen crash on startup · deltachat/deltachat-desktop@37adfe2 · GitHub

If you need any more information please ask

Thank you

Works for me inside weston (weston running under X in my case), for some reason the window bar/border is missing:

$ deltachat --enable-features=UseOzonePlatform --ozone-platform=wayland
$ electron --version

The white screen bug was that the lastAccount value in ~/.config/DeltaChat/config.json was a string and not a number, delete the key to fix it manually, but 1.22.2 was specifically made to reset it to null when its a string and not a number, so I think that’s not your issue.

Note that deltachat is currently developed on electron 13 and also shipped with it on non AUR packages.

Does running electron --enable-features=UseOzonePlatform --ozone-platform=wayland work inside of wayland?