Editing not working

Delta Chat version


Expected behavior

In a chat, when sending an image file, I tap the pencil icon, choose a tool and use it, then tap the check icon to save the changes and send it.

Actual behavior

It seems that tools are been used, but image stays the same (you’ll see it in the pictures). Pencil and the-thing-that-seems-a-flashlight don’t work, emojis can be added but can’t be resized, same with text.
This is not new, I jump from 0.20 to 0.200, and ever since I’m having this going on.

Steps to reproduce the problem

  1. send a picture
  2. edit it
  3. select a tool (e.g. pencil)
  4. use it. Can you see the trail of your finger? If no, you have this problem :frowning_face:

Screen snapshots

Debug logs
This is kind of big, so I ask if this is really needed.

Other stuff
I’m using Oreo (8.1) on a Samsung J7 Prime 2018, and none of my relatives nor friends have this issue.:rage:

1 Like

this already has a bug report here:

ok, you didn’t tell me. However, you can update the info.

can someone with the error tell if this is working using signal on the same device? (we’re using basically the same activities as signla for painging on images)

Is this Signal?
I’ll test it and tell you.

1 Like

yip, this is signal. thanks for testing :slight_smile:

Not working for my country (Cuba) right now, sorry.:confused: I’ll test again later.

Finally I gave up on Signal after a week :frowning_face:
But this seems to be a DC thing, every other editor of different messaging apps I’ve tested (WhatsApp, Telegram,… ) worked just fine.
Since I’m the only one struggling with this, I’m happy for all of you who aren’t :cry:

1 Like

Massick what r10s means is that Delta Chat UI code is from Signal, so if you test Signal and it has the same problem that would save a lot of time, so we could know is a Signal bug and not a bug introduced by Delta Chat :wink:

I know that. Read the messages again. I can’t test Signal (give it a try yourself). I also said that in my phone this is a DC thing, and then I mention the other apps.

On Delta Chat v0.500.0 the problem persists. I updated manually (and prayed) but still not working.

If someone provides a Signal APK for you, can you test?

I tested (or tried to), but Signal doesn’t work (open) in my country, at least it didn’t send me any code in the few hours I waited for it

we’re about to update the editing-activity, eg. adding a crop-function and updating larger parts of the old edit-code. with chance, this fixes the problem, not sure.


I’m happy to know that. I hope with fingers crossed. :smile:

1 Like

Problem solved!
This 0.510.1 version looks really good.
Thanks to everyone involved.

cool, thanks for checking again!

1 Like