GMail/Oauth works again with Delta Chat

Thanks to the tireless work of @r10s , @Simon and others, and after three videos produced for the Google Cloud review department, we are happy to announce that Gmail/OAuth works again, in effect for all existing installs now. See also https://twitter.com/delta_chat/status/1177755702883958784

6 Likes


app version, email provider and error message on the image. please help. thank you. :wink:

Sorry for separate post because of “Sorry, new users can only put one image in a post.”

We don’t have oauth in desktop yet, you need to either use an app pasword or enable ‘less-secure-apps’
Also some more context than an image would be nice.

1 Like
  1. Less secure apps now are enabled:
  1. Another error msg pops up:

Looks like a bug. You can try putting the google settings manualy under advanced on the login screen. (server address, port and so on).

semi-Technical background of this message:
Delta Chat tries to figures out what the server address is and somehow came across an invalid xml file or the parser has just problems with it - so it doesn’t know the address of the google mail servers (imap and smpt) and thus can’t connect to it.

there are lots of improvements since the current desktop-version, eg. the weird error message was fixed at https://github.com/deltachat/deltachat-core-rust/pull/698 .

it is planned to ship a new version for all platforms these days; this might fix the problem at all :slight_smile:

1 Like