Imap over port 993 failed

I have just installed the Android version of DeltaChat and tried to connect our mailserver (Mailsite, Hochschule). Our mailserver is configured to use port 993 only (TLS). I can setup this port in Deltachat for imap but after some time it complains that it could not connect over port 143 (regular imap, that is blocked by our firewall)

DeltaChat should only use the configured port

Confirm exactly the same problem with aol mail servers.

Friend of mine used DC with c-core in the past. It worked fine.

But now with current rust-core (Android DC v1.1.2) new installation isn’t possible any more. IMAP Port 993 is needed but DC forces 143.

Opened an issue at deltachat-rust-core

AOL isn’t working for a different reason - they only offer authentication via OAuth2 now: https://providers.delta.chat/aol

If you care a lot about this provider, consider contributing on this issue: https://github.com/deltachat/provider-db/issues/91

You could open an issue at https://github.com/deltachat/provider-db/issues to add your mailserver :slight_smile: This makes it easier to connect to it through Delta Chat.

Hi, I opened an issue and saw that meanwhile it’s solved. Someone else (missytake) has been testing my findings and: It seems to work :slight_smile:

AOL account settings needs to be more prepared than before. See provider db.

Delta Chat only tries port 143 if port 993 failed. So the connection failed for a different reason. The error it shows is not very useful, yes - this is a known issue.