No Contacts shown on wrong E-Mail field

Hi guys,

I’m about to use DeltaChat with my team of associates. While setting up I stumbled upon two issues. The first one I won’t discuss here in order to stay on topic (crash on setup process). I’ll probably open another thread for that.

After having been able to setup everything I realized that no contacts are shown in the Android App (1.2.0). Only the log provided by Logcat Extreme pointed me to a message about “Bad address for contact…”.

I then found, that I had accidentally typed a phone number in an email field of a contact. This lead to DeltaChat not displaying any contact except my own.

To reproduce the error you would have to setup DC again with a faulty contact. Changing a contact to a wrong email address does not make DC show zero contacts (fortunately).

hi, @b0wtie - first of all, welcome aboard!

thanks for filing the issue, i tried to reproduce that, however, i already failed in entering a phone number as an email address, this seems not be accepted by the android app. how did you manage to do this? and then, delta chat does no longer show any contact? interesing issue :slight_smile:

Hey @r10s

thank you for your welcoming words!
It is a Nextcloud addressbook synced via Dav x5. With that setup and the default AOSP contact app it is possible to enter anything into an email field.


I’ve just reset the whole app via TitaniumBackup, deleted it’s folder under Android/data and started anew. Before setting up DC I added an Email Address “12345678” to my friend’s contact entry.

This can be seen in the log:
03-01 15:35:50.886 15457 15866 W DeltaChat: ThreadId(22) src/ Bad address "12345678" for contact "Felix Sonneborn".
And yes, no contact is shown, only my own.

All it takes to make all my contacts show up is to edit the Felix’ contact and remove the bad address. Reopening Deltachat and there they all are. I tried with DeltaChat 1.1.2-gplay and with 1.2.0 from the website.

1 Like

thanks for the detailed description, now i see.

there is a bad address in the system’s address book which results in no addresses to be imported from there. this is not good, indeed, i’ve filed an issue for this at

however, you should be able to add addresses manually,

also, if you fix the error in the system address book, the import should be redone as soon as you open the contact list again.