[Solved] Can't import backup (Android)

Delta Chat version

Tested with 1.34.5 and 1.32

Expected behavior

Select a backup file to import to DeltaChat

Actual behavior

Impossible to select a file

Steps to reproduce the problem

  1. Install DeltaChat for the first time
  2. Select “Restore from backup” in the welcome screen
  3. Chose backup-file to start restoring the backup

I have tried on two new devices Samsung Galaxy S10e and Galaxy Tab S7 and on my personal Galaxy S10e (LineageOS). On all devices the same result: The bak-file can’t be selected. All files look like hidden or inactive.
I have granted deltachat the rights to access media files as requested.

The backup file looks good. I opened a copy of it with SQLiteDatabaseBrowser and was able to read all my messages.

What am I doing wrong? Is there something I forgot to do?

Hello :wave:,

Shouldn’t the backups be in TAR format?

1 Like

Thank you very much!
I could validate this with my device.

My wife’s device was some years old and she had a warning that her DeltaChat app was old, but she couldn’t update any more. The backup file of this device is a bak-file.

So I think there is no way to import the old data?
I already tried a new setup. This worked for the chats but not for the “saved messages” that she used like a kind of notepad…

Wasn’t so hard after all :grinning:

Installed DeltaChat 1.14.5 from F-Droid
Successfully restored the backup
Updated DeltaChat with F-Droid

Now everything is fine.

Thank you for your help!