Videochat with Webex


I’m testing dc at the moment and i’m realy into it. :grinning: I normaly try to find the solutions to my problems in the internet, but for this I could not find anything … yet … :wink:

I’m using the windows desktop version 1.14.1 and Android 1.14.5. A friend is helping with the apple side, but i don’t know which version she is on. The latest apple one, i guess. :grimacing:

Actually I try to get the videochat running. The poison of choice for me is Webex, as we use it at work.
Webex gives me a personal room with a permanent URL. No changing sufix required. It looks like “
It works just fine when used in a browser. Windows and Android both try to run the native app and, if not found, offer to use the browser version.

This URL I put into the configuration in windows, as well as the android app.

Unfortunately dc appends some random? string and therefore Webex can’t find the called meeting.

The resulting URL looks like “

In windows I found a trick and appended “/?something” to the URL. The webexclient seems to ignore the unexpected variable (the leading questionmark implies “something” is one) and opens the personal room. The android app is not so forgiving and throws an error :unamused:

Is there a way to stop dc from appending anything to the given URL in “Videochat-Instanz” (I’m not sure what the english configuration name is, as I only use the german software)?

Thanks for any help in the matter!



the random room name is required to allow different rooms for different chats, it feels a bit weird - and even a bit dangerous - to me to use the same room for all chats - esp. as persons that do not know each other can land in the same room then.

for these reasons, Delta Chat always adds a random string representing the “room” to the URL (the “room” is added to the end of the URL or at the postion where you write $ROOM in the URL).

however, a slightly modified /?something trick could do the job, maybe try$ROOM

with chance, also the app ignores the part behind #. we could also think about a method not to add a roomname at all, maybe by adding $NOROOM to the url, however, i’d like to target the initial issues before and understand the usecase a bit better :slight_smile:

also this should work:$ROOM
1 Like

Thanks to both of you. I tried your suggestions and they both worked with the Windows-Client, but again not with Android :unamused:

I guess Android does not mangle the URL in any way, but just puts it through to the client.
If so, r10s idea with $NOROOM seems to be a good one if this leaves an unchanged URL. It would solve the problem for all video chat clients, with special needs for the URL.

Is there any other (already existing) way to supress the expansion of the URL?

Use case info:

The “personal room” with webex is not allways open! It has some kind of “hallway” where visitors have to wait, until I open it up. (If I’m not already there that is :wink:) It’s my room and mine alone. :+1:

I can configure it to send an email, if someone enters the halway. A kind of door bell …

In delta chat, if I send an invite (the troublesome URL) then I’m redirected directly to my own room - opening it up. There I wait for the other party to arrive. Bingo!

After my partner(s) arrived, I can close the door manualy or after a configured time, so no one can “bomb” our chat in progress.

This works perfectly … but in windows only :grinning:

thanks for the details, sounds reasonable to me.

i’ve suggested a change to support a $NOROOM parameter at

As I understand GitHub your change has been approved and merged already.
Because it is in the core, it should worke in alle clients.
I append $NOROOM and therefore nothing will be added to the URL.

Is that correct? Anything I forgot? Anything more I have to do, other then testing?

yip, it is in the core, however, since then, no official client releases have been done. so, in 1.16 the option is note yet available.

upcoming releases based on the new core will get the feature, of course.

until then, you can try out nightlies or preview builds, if that is an option for you - or just wait a bit.

once you have a version supporting $NOROOM, of course, it would be great if you can report back your experience here.