Setting x-scheme-handler on linux system to enable forum login via DeltaChat Desktop

Delta Chat version
Version 1.40.4 (git: v1.33.0-320-g70746da6)
Expected behavior
Click on manual link option and DeltaChat opens login link and authenticates to forum via login bot
Actual behavior
DeltaChat does nothing, does not open link.
Steps to reproduce the problem

  1. Visit
  2. Select DeltaChat login option
  3. Click on manual link button under QR code

Screen snapshots
Will add later
Debug logs

Logs No logs because DeltaChat is missing mimetype

So for I have tried adding the following to ~/.config/mimetypes

[Added Associations]

This will cause DeltaChat to launch, but it still doesn’t load the link.

If I click to button to copy the login link to the clipboard, then navigate via the terminal to the appimage /tmp directory, and manually run this command, the login bot is launched in the desktop app, and it successfully authenticates to the forum.

./deltachat-desktop ''

So I think I’m halfway there, I just need to tweak either the deltachat.desktop xdg file, or my mimetype x-scheme-handler and it should work.

Here’s my xdg shortcut contents .local/share/applications/deltachat.desktop

Name=DeltaChat (1.40.4)

Figured it out with some help from this Appimage github issue

The secret is to add %u to the end of the xdg shortcut exec= line, like so

Exec=/home/user/Applications/DeltaChat-1.40.4.AppImage %u

1 Like

Is this desktop file included in the app image or where does it come from?
You can also test with 🧪 Help testing the upcoming 1.41.X release, maybe it was a bug in the packaging tool we used that could be already fixed meanwhile?

No I homerolled it.

There’s a pretty cool app for Debian based systems called AppImageLauncher that will create them automatically for you, but it doesn’t work on Gentoo.

1 Like